IBM Cloud Kubernetes and Kubeflow Compatibility

Compatibility matrix for Kubeflow on IBM Cloud by Kubernetes version

Compatibility

The following table relates compatibility between Kubernetes versions 1.19+ of IBM Cloud Kubernetes service and Kubeflow version 1.4.

IBM Cloud Kubernetes Versions Kubeflow 1.4.0
1.19 Compatible
1.20 Compatible
1.21 Compatible
1.22 Incompatible see istio/istio#34665
  • Incompatible: the combination is not known to work together
  • Compatible: all Kubeflow features have been tested and verified for the EKS Kubernetes version
  • No known issues: the combination has not been fully tested but there are no reported issues

Next Steps

    1. Go here for installing Kubeflow on IKS